CentOS6 wpa_supplicantが動かなかった。

# lsusb
Bus 001 Device 002: ID 2019:ed14 PLANEX GW-USMicroN

を動かすまでの足取り

CentOS6.9 /wo PAEを作ってminimalから再設定中。iso内で依存関係が壊れていますと表示されたのはこれのせい?

wpa_supplicantが動かずにどうしようかと。どったんばったん。

設定を変更した箇所。

# cat /etc/sysconfig/wpa_supplicant
INTERFACES="-iwlan0"
DRIVERS="-Dwext"
(以下略)
# wpa_passphrase ichigo-wifi ichigopass
network={
        ssid="ichigo-wifi"
        #psk="ichigopass"
        psk=c9b6a21410c48f10e71c9d47e77362ed1f1981d96e76ff86b6fdbca75a47dfc3
}
# cat /etc/wpa_supplicant/wpa_supplicant.conf
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0     ★wheelを指定。
ap_scan=1
network={
        key_mgmt=WPA-PSK
        proto=RSN
        pairwise=CCMP TKIP
        group=CCMP TKIP
        priority=2
        ssid="ichigo-wifi" ★wpa_passphraseの内容
        #psk="ichigopass" ★確認できたら消す
        psk=c9b6a21410c48f10e71c9d47e77362ed1f1981d96e76ff86b6fdbca75a47dfc3
}
#cat /etc/sysconfig/network-script/ifcfg-wlan0
DEVICE=wlan0
ONBOOT=yes
BOOTPROTO=dhcp
MODE=Managed
KEY_MGMT=WPA-PSK
TYPE=Wireless
PERSISTENT_DHCLIENT=yes

一部いらないかも知れないけど、これだけ設定しても動かない。

/var/log/wpa_supplicantを見てみると。

dbus: Could not acquire the system bus: org.freedesktop.DBus.Error.FileNotFound - Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory

iwconfigで設定を入れてもあがらないし、このメッセージをみると、そもそもだめ風味。

# yum -y install --disablerepo=* --enablerepo=c6-media dbus

 

と追加することであっさり動くようになりました。

# chkconfig messagebus on
# chkconfig wpa_supplicant on

昔は毎回。

modprobe rt2800usb
echo "2019 ed14"> /sys/bus/usb/drivers/rt2800usb/new_id

とか必要だったので、どこかでひそかに直っている。