CentOS6 apache2.4を放棄した件

パッケージで入れようとすると依存関係とかではじかれたりなんだりと。

CentOS6でapache2.4を使うにはパッケージの関連で不整合が出る。nghttp2がーとかServer’s Module Magic Numberがーとか。

apache2.4.3位になると、apiの名前が変わって微妙な不整合に。

ということで、コンパイルをしてちょこちょこいじったけど、apache2.4は放棄状態となりました。

apache2.2 + php7.1あたりで遊びますが、ここは失敗の記録だけ。

# cd /usr/local/src

# wget http://ftp.jaist.ac.jp/pub/apache/httpd/httpd-2.4.25.tar.gz

# tar zxvf httpd-2.4.25.tar.gz

# ./configure –prefix=/opt/httpd24 –enable-mods-shared=all –enable-ssl –with-ssl=/opt/openssl
checking for chosen layout… Apache
checking for working mkdir -p… yes
checking for grep that handles long lines and -e… /bin/grep
checking for egrep… /bin/grep -E
checking build system type… i686-pc-linux-gnu
checking host system type… i686-pc-linux-gnu
checking target system type… i686-pc-linux-gnu
configure:
configure: Configuring Apache Portable Runtime library…
configure:
checking for APR… no
configure: error: APR not found. Please read the documentation.

APRが無いと怒られました。

# cd /usr/local/src/httpd-2.4.25/srclib/

# wget http://www-eu.apache.org/dist//apr/apr-1.5.2.tar.gz

# wget http://www-eu.apache.org/dist//apr/apr-util-1.5.4.tar.gz

# tar zxvf apr-1.5.2.tar.gz

# tar zxvf apr-util-1.5.4.tar.gz

# mv apr-1.5.2 apr

#mv apr-util-1.5.4 apr-util

# cd ..

# pwd

/usr/local/src/httpd-2.4.25/

# ./configure –prefix=/opt/httpd24 –enable-mods-shared=all –enable-ssl –with-ssl=/opt/openssl

./configure –prefix=/opt/httpd24 –enable-mods-shared=all –enable-ssl –with-ssl=/opt/openssl –with-mpm=prefork

configure: error: pcre-config for libpcre not found. PCRE is required and available from http://pcre.org/

こんどはlibpcreが無いと怒られる。pcreをmake installしてもよいかもしれない。

#  yum -y install pcre-devel

再挑戦で通過?pcreもmake/make installしたりもしてみたり。

Server Version: 2.4.25
Install prefix: /opt/httpd24
C compiler: gcc -std=gnu99
CFLAGS: -g -O2 -pthread
LDFLAGS:
LIBS:
CPPFLAGS: -DLINUX -D_REENTRANT -D_GNU_SOURCE -D_LARGEFILE64_SOURCE
C preprocessor: gcc -E

# make

通って動くことは動くけどphpの連携とかに無理が出るので、結局apache2.2を使うことになりそう。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です